Layout Quick Open
KeyCreator \ Layout \ Layout-Quick-Open

Location: Layout>Layout Quick Open

This function provides rapid entry into a given layout. Its intent is to provide a 'quick look' into a layout forgoing the typical reprocessing of instances (which updates a layout to the current model mode content for instance.) Files that were saved in drawing layout mode will open in Layout Quick Open. This holds true for loading assembly files which contain references that have layouts associated with them.

Files previous to KeyCreator 2012 (KC11.X) will need to be reprocessed due to file format changes and a reprocess dialog is provided to perform the action. In general any actions that would typically require a reprocess will open a reprocess dialog. A manual Reprocess function is provided in the Layout drop down menu and the right click Layout context menu (reprocess will automatically occur when entering a layout in the standard Layout Toggle method.) When printing, Exporting or copying from a layout opened in Layout Quick Open mode a warning will indicate that a reprocess should be performed.

Visual indicators are provided to indicate that the current mode is Layout Quick Open and include a large exclamation point in top left of layout display, a red border in layout display and an exclamation symbol in the Tree Window. A File>Print done from a non-reprocessed Layout Quick Open session will have the exclamation print with the layout.

Using the Function:

  1. Choose File>Open and open an existing KeyCreator file. If the file was last saved while in layout mode it will automatically open in Layout Quick Open mode. If the file needs to be reprocessed a dialog will prompt for reprocessing.

  2. Choose Layout>Layout Quick Open and the last loaded layout will open in this mode.

  3. Modifications can be performed but if any modifications require a reprocess a prompt for reprocessing will occur.

Items Not Processed with Quick Open Include:
  • Hidden Line Renderings of instance

  • Silhouettes in instance.

  • Section views.

  • Detail callouts.

  • Instance border auto fit and auto center

  • Some instance resizing.

Items Processed with Quick Open Include:
  • Details and dimensions associated to model mode changes.

  • Non-hidden line instances.

  • Wireframe edges where used in an HLR.