Lightweight
KeyCreator \ Assemblies \ Edit \ Lightweight

image\ASSEMBLIES_lightweight_icon.gif

Location: Assemblies>Edit>Lightweight

This function allows you to display a part reference in "Lightweight" mode. This is similar to the "Suppressed" mode in that the full geometric data of the referenced part is not loaded in memory. Instead, a lightweight stream is loaded and displayed. This allows visualization of the reference model, without the overhead of the full geometric data. When a part reference is lightweight, the geometry exists only in the display and can not be selected independently of the part reference for any operation, including position selection. The full geometry data can be loaded when necessary for operations by turning off the lightweight option for that reference. When the operations are completed, the lightweight option can be turned back on again. Note that dimensions to these references will become suppressed when this is done. 
 
In order for displaying a reference as lightweight to have any effect, the referenced level set must have the "Streamed" option turned on. This is optional so that users who don't use the assemblies functionality do not incur the additional save time and file size required to maintain the lightweight stream in the referenced file. The default level set in each part has this option disabled by default. All other level sets will have this option enabled by default. This option is available in the Level Sets pane of the Parts Splitter. When you attempt to apply the Lightweight function to a part reference and the function does change the part to lightweight, a message appears indicating this. With the message, in the Lightweight column of the Part Reference pane of the Parts Splitter, the check box in the part's row is unavailable (gray). Usually, the problem is that the Streamed option on the Level Sets pane of the Parts Splitter is not selected, as the message indicates.

The following locations and controls are relevant to Lightweight: Assemblies>Lightweight; Part Splitter>Part Reference (Lightweight column); Assemblies>Create Reference>open a file>Options tab (Lightweight reference for visualization purposes only check box); Part Splitter>Level Sets (Lightweight column); Part Splitter>Level Sets>Streamed column.

Using the Function:

  1. Open a model that has a part reference. 

  2. Click Assemblies>Edit>Lightweight. The Conversation Bar appears. 

  3. Select the desired part reference(s) in the Viewport. 

  4. Click Accept. The lightweight flag toggles for each selected reference.