Animate
KeyCreator \ Tools \ Machinist \ Path \ Animate

image\NCanimatecutter.gif

Location: Tools>Machinist>Path>Animate

Use this feature to animate a toolpath. When this feature is selected, a dialog appears (see below). Once you have configured the settings contained in the dialog, you are prompted to select the toolpath(s) to animate. The selected path(s) change to the current highlight color, set under File>Properties>Colors/Attributes. For in-depth coverage of each function within Machinist use the MachinistRefManual  .

 

Using the Function:

  1. Click Tools>KeyMachinist>Path>Animate. The Tool Path Animation dialog appears, through which you are able to specify Initial Tool Motion. Once you have configured the available dialog settings, select the OK button option.

image\IMG00622.gif

Draw

Specify a numerical value from one (1) to ninety-nine (99) for the drawing speed, one being the slowest speed.

Initial Tool Motion
  • Continuous – When selected, the tool motion will be continuous until the path is completed.

  • One Pass – When selected, the tool will animate across the part on one pass, and will then wait for the user to select either ENTER or ACCEPT to start the motion for the next pass.

  • Point to Point – When selected, the tool will move from point to point along the tool path.

  1. Select the toolpath to animate. Select the ACCEPT button option when finished.

  2. Indicate the toolpath origin, or select the SKIP button option if you intend the origin to be 0,0,0.

  3. The toolpath changes to the current highlight color, and begins to animate at the speed you had defined in the Tool Path Animation dialog. To increase the speed, use the + key. To decrease the speed, use the – key. To return to the menu, select the ESC button option. After the toolpath animation has finished, select the ACCEPT button option to continue.