Create a BOM
KeyCreator \ Tools \ BOM-and-Table \ Create-a-BOM

(If you clicked the Help button on the Virtual Objects dialog box, click here.)

Location: Tools>BOM and Table>Create a BOM

Use this function to create a Bill of Materials (BOM). The BOM is based on data illustrated in the figure below.

Using the Function:

  1. Create a table definition file by following the Create Template procedure.

  2.  Click Tools>BOM and Table>Create a BOM. The BOM dialog appears, like that shown below under Dialogs. The tree located at the left of this dialog is a BOM list related to the current part. You can define as many BOMs as desired with different configurations.

  3. If no BOM is listed, click the Add button. The Edit Category Template dialog appears.

  4. In the Template field, select the template file for the default Category. This is the BOM template that will be used for the BOM you are creating. Note that, if you want to make the template file relative to the part (that is, relative to the open .ckd file), click the Make Relative button.

  5. Expand the tree on the BOM dialog by clicking the plus sign. Note that clicking

  • Data displays the Data pane, and clicking the Preview button on this pane displays the preview dialog box

  • Output displays the Output pane

  • Balloon configuration displays the Balloon pane

  1. Configure the BOM dialog and related panes as desired. (See Dialogs, below, for descriptions of options.)

  2. On the Output pane, select the kind of output you want (if any is required).

  3. Click OK.

 

Dialog Options:

Below, are illustrations and descriptions of BOM dialog elements and its panes.

 

Buttons Common to BOM dialog and panes:

Add Button

Click to add a new empty BOM.

The Edit Category Template dialog appears, as shown below.

 

Select the desired template (make relative if desired) and click OK. (See step 4 above regarding the Make Relative button).  The tree that appears in the BOM dialog at the left is related to the current part. The right side of the BOM dialog contains the fields illustrated below under BOM Dialog Example.  

Copy Button

Create a copy of the selected BOM. The new object is named "Copy of <object name>"

Delete Button

Remove the selected BOM

OK Button

Exit the function accepting all the changes. The whole BOM is recalculated, all the external files are rewritten, all tables are updated.

Cancel Button

Exit the function cancelling all the changes done during the session

Help Button

Open the Help system

BOM Dialog Example:

Tree on left shows the BOM list related to the current part

 

Name

Name of the BOM

Disable Balloon Text Upgrade

If selected, the assigned balloon numbers will be considered fixed and will not change in case of item remove or other operation that could change their values.

BOM Type

(Unavailable until future release)

Category Data

Allows the subdivision of the BOM items in different groups using a different template for output. The category data defines which is the field representing the category, so that the BOM will be able to sort the items. For some fields, the Parameter field will also appear. For example for a File User Property, the user property name must be indicated as parameter.

Balloon

Indicates the table column to be used to fill the balloon text

Template Table

Defines the different ways to fill the table depending on the Category field. Allows you to sort the BOM items based on different categories. Tables are filled following the order of this list. For each category, you can indicate a BOM template file. Select one of the rows in the table and click the Edit Selected button. A dialog then appears asking for data. Note that this assumes all templates are using the same table definition.

Print file list

When clicked, the system generates a report indicating the files used by all of the bill of materials for the current part. The report also indicates any missing files.

The following buttons allow you to work on the template table:

Add Category

Adds a row to the table

Delete Category

Removes the selected category. (Note that the <default> cannot be removed.)

Move Up

Move up the selected row

Move Down

Move down the selected row

Clear All

Clear all data in the table

Data Pane Example:

After you specify the main configuration data (previous dialog), proceed to the Data pane. This pane indicates the entities to be included in the BOM and has buttons to manage them.

 

Move Up and Move Down

Allow you to move the selected item up or down. This allows you to determine the order in which items are listed in the BOM.

Add/Remove Entity

Allows you to add or remove entities (part references and composites) to the BOM. Clicking this button closes the dialog and the system highlights any entities already included. You can use the selection menu on the Conversation Bar to add or remove entities. Clicking Accept on the Conversation Bar then adds or removes the entities from the Data pane.

Preview

Displays the dialog box shown below. This dialog provides a preview of the BOM tables.

 

Add V. Obj

Allows you to add or remove the available virtual objects. A dialog appears with a list of all available virtual objects so you can select or deselect them, using the standard Windows controls (CTRL or SHIFT).

Add Balloon

Allows you to add a balloon to the drawing: select the desired row and click this button. The dialog then disappears. The related parts are highlighted. The system prompts you for the arrow position and the text position, and it adds the balloons.

Highlight

Closes the dialog temporarily and highlights all the elements included in the BOM. Pressing ENTER makes the dialog reappear.

Add V. Obj for Item

When you select one or more item and click this button, the system automatically generates virtual objects with the same name and data of the selected items. The system adds these to the BOM. You also are able to add new virtual objects, which also  are added to the BOM. The dialog that appears is the same as that for the Create Virtual Object function.   

Output Pane Example:

Allows you to create BOM tables (Position Table button), to disassociate a table (Disassociate Table button), or export to a file (Export to File button).

 

Balloon Configuration Pane Example:

Allows you to define the type of balloon to be used for the BOM.

 

Note the following:

  • When you delete a referenced part or a composite, the software automatically recalculates the BOM.

  • If you delete parts, the software deletes all related table rows, removes all related balloons and recalculates all of the external files.

  • A table that the BOM function creates is not editable unless you disassociate it.