Tree Window features tabbed panes: Design Files, File Explorer, Verify Tree and NC Tool Path"> Help | Kubotek3D

Tree Window
KeyCreator \ View \ Control-Bars \ Tree-Window


Location: View>Control Bars>Tree Window

The Tree Window features tabbed panes: Design Files, File Explorer, Verify Tree and NC Tool Path. This window is dockable, and can be moved from its default location once it has been activated. Display of this window is toggled on/off through the View>Control Bars submenu. The active tab in the tree window is saved in the workspace file, and restored when the workspace file is reopened. It is also saved to the registry for when no workspace file is used, or the workspace file does not include a value for the active tab. Following is a description of each pane in the Tree Window.

 

Design Files:

The Design Files tab displays a tree structure of all open design files, as well as the model(s) and layout(s) that they contain. Inside the Tree Window, the active part is marked with a red checkmark, similar to the way active levels are distinguished in the Levels window. The active part name is displayed in bold text.

 

If you have a .CKD file open that contains a drawing layout (or multiple layouts), the layouts will appear in the window as a subset of the Part. You can right-click on the layout name and choose "Open" to load the layout. You can also rename and delete the layout from this right-click menu. See the Layout Mode section for more information on drawing layouts.

You can right-click on the Part name and choose "Edit Part" to exit layout mode and return to modeling mode.

File Explorer:

The File Explorer tab allows you to view the drives, files and folders on the computer, similar to the explorer pane in Windows Explorer. All of the files that match the extensions recognized by the File Open function are listed.

Right clicking on any node in the tree will display a context menu with two options: Browse Mode and Properties. The Properties option will display the properties dialog, like Windows Explorer. Browse Mode will toggle File Browsing Mode on/off (see below).

The Browse Mode toggle can also be accessed by the following methods:

  • Menus: Edit>System Settings>File Explorer Browse Mode

  • SDK: ck_set or ck_inquire (CK_SET_FILE_EXPLORER_BROWSE, nValue)

  • KXL: SET or GET BROWSEMODE, 0/1

Right clicking on a file node in the tree will display a context menu that also has an Open option, which allows you to open the file.

When in File Browsing Mode, left-clicking on a file in the tree will open that file. In addition, if the active part is not modified, the file is automatically closed. Any file opened in the File Explorer window while in Browse mode will be autoscaled.

Verify Tree:

When Verify is selected, it shows a tree with the result of the recent Verify operations, such as Verify Entity, Verify Position, etc. (Verify operations are functions selected from the Tools>Verify menu that allow you to gather information about the model you create.) You can set a limit to the Verify Tree history in Tools\ Application Options\ Startup.

NC Tool Paths:

This tree represents tool paths and tools present in an NC CKD file. Through a right click in the Tool Path tree, you can perform all NC operations otherwise performed using Tools>NC menus or the NC palette.

The following list summarizes the usage of this tree.

  • Provides a method for selecting toolpaths from a list (Tree) in addition to the method of selection by picking tool paths (that is, composite entities from the screen). Allows concurrent selection from the tree and the screen and highlights the selected toolpath(s) both on the screen and on the tree.

  • Displays information about the toolpaths created in the part file, including geometry used to generate the toolpaths

  • Displays tool descriptor on the tool node

  • Attaches bitmaps for group, tool, geometry and toolpath (The bitmap varies, depending on the toolpath.)

  • Provides the ability to reorder toolpaths within a group: (a) by dropping a toolpath onto another toolpath, the source toolpath is dropped below the target; (b) by adding a toolpath to the top of the group, the toolpath is dropped onto the group node

  • Stores the groupings of the toolpath in the partfile

  • Automatically represents NC toolpaths in the tree when you open a file containing NC toolpaths

  • Provides the ability to copy toolpaths by dragging them from one group to the next while holding down the CTRL

  • When no toolpath group is present n the file an empty toolpath group is shown by default in the tree view

  • Reorders toolpaths only within their groups. To move a toolpath from one group to another, drop it on the target group node. It is now the first toolpath in that target group node. Now you can move it to the desired toolpath location in that target group node.

  • Shows names of toolpaths using this format: toolpath number (=node number) - Kubotek-generated toolpath type name – user-defined toolpath name. For example, 4-CONTRGH-MyContourRoughing.

  • Renumbers automatically toolpaths from the top down at any movement, addition or subtraction of nodes

  • Allows selection of multiple toolpaths

  • Allows you to suppress the application of all NC functions on the selected toolpath. To accomplish this, right-click the node and select "Suppress" from the drop-down. "S" appears beside the node.

  • Allows you to hide the representation of the toolpath on the model. To accomplish this, right-click the node and select "Hide" from the drop-down. "H" appears beside the node.