Settings Export
KeyCreator \ Tools \ Settings-Export

Location: Tools>Settings Export

Use this function to export settings of the current KeyCreator session to an archive file that can be imported into a new installation of KeyCreator. The file has the extension .ksa (KeyCreator Settings Archive file). Only settings that have been changed from their default values are exported. Importing this into an existing installation that has been configured already may not make the settings match exactly.
 

Using the Function

1.       While in a KeyCreator session whose configuration you want to export, click Tools>Settings Export. The Settings Export dialog box appears, as shown below under Dialog Options.

2.       Select the options on the Settings Export dialog box, as desired. The .ksa file will include general settings of the session. You can add more information to the .ksa file if you select one or more of these options.

3.       Click OK. The Select Settings Export Filename dialog box appears, allowing you to name the .ksa file and save it in the folder you want.

4.       Select the desired folder, name the file and click Save.

Dialog Options

 

Include Keyboard File in settings archive

Select this option to export the contents of the .kbd file used in this session to the .ksa file. The .kbd file contains information defining shortcut key assignments. See Creating Keyboard FilesCreating_Keyboard_Files.

Include Workspace File in settings archive

Select this option to export the contents of the .wsp file used in this session to the .ksa file. The .wsp file contains information defining content and appearance of the KeyCreator interface. See WorkspacesWorkspaces.

Include Default and PRT templates in archive

Select this option to export the contents of the .ckt file used in this session to the .ksa  file. The .ckt file is a template file. It contains information defining part-customization settings and display colors. See Using Templates.

Include all registered KXL files in archive

Select this option to export the contents of the .kxl files registered at Tools>Options>KXL. Also exported are the supporting .txt files that provide the description text for those .kxl files as well as the .bmp files that provide the toolbar icons. See KXLHIDD_MACRO_PAGE.