Write Report it can be viewed using this function. "> Help | Kubotek3D

Read Report
KeyCreator \ Compare \ Read-Report

Location: Compare>Read Report

Once a report has been generated using Write Report it can be viewed using this function. The report is opened external from the current session (unlike the Run and Load Report options.)  Note that reports can have several formats including htm, pdf, ppt or simple text .rpt formats. If password protection was used in the generation of the report (common in the .pdf format)  then a password will be needed to view the file.

Using the Function:

  1. Choose Compare>Read Report brings up a file open dialog.

  2. Navigate to the file location and choose Open will open the report in the appropriate application ( MS Notepad for .rpt reports for example.)

  3. If a file open error occurs (no application found to open file type) you will need to load the necessary application (such as Adobe Acrobat Reader for .pdf files.)

Report Content

KVT Version

This line item of the report shows the exact version used to run the compare session. Above shows the ECO manager version the release designation (V11.5.1) and the build number 2255.

File incription

This segment is used to provide tamper resistance to the file. Along with the checksum entry, any alterations will be flagged in the file and the report is considered tampered.

Proprietary Notice

A brief non-disclosure section is provided for the report.

Login Traceability

The provided time/date, unique user ID, report author and any serial number provided (in Tools>Options>Analyze>Report Options) is provided for traceability purposes.

File Traceability

This section provides the path to file, file name, part name, file size and file origin for both the master/'Was' and Copy/'Is' files used for this report.

Options Used

The first line of this section shows the path to the options file used for the report and the option file name. Options used will appear as set in the options file (derived from settings in Tools>Options>Analyze Options. Note that a false indicates the option is not turned on/utilized in this report (true indicates the option is being used.)

Analyze Section

Analyze Report Status- The first line in this section indicates if any error are reported. When using the Abridged report option (Tools>Options>Analyze Options>Report Options>Report Control) the match/unmatched data will be omitted from the report (this line would be the only indicator of errors encountered.)

Match/Unmatched-  When show all is chosen in Report control, both matched and unmatched entity results will be written in the report, if using the Difference options only the unmatched will be written to the report file. Note the entity number on the line which can be used to find the entity using the Compare>Display>Find ID function.

Actual- This shows the result values found for the given entities.

Nominal- This shows the expected values for the given entities.

Deviation- This shows the overall difference result between the Actual and the Nominal values.

Out of Tolerance- The value deviation from the set tolerance threshold (set in Tools>Options>Analyze Options>Tolerance settings.)

Analyze Summary- A summary of analyze results at stated precision value.

Mass Properties- Results for this section depend on settings used in Tools>Options>Analyze Options>Secondary Options.

Geometry Count-  Results for this section depend on settings used in Tools>Options>Analyze Options>Secondary Options.

Topology Count- Results for this section depend on settings used in Tools>Options>Analyze Options>Secondary Options.

Validation Time- The amount of time  taken to process the above results.

Checksum- An auto generated code that is used to provide tamper ressistance.

QA Approval- Provides a QA sign off line for the report.