Batch
KeyCreator \ Compare \ Batch

Location: Compare>Batch

If dealing with multiple 'Is'/'Was' comparisons use the Batch to manage the process from setting options to saving session reports.

Validate Parts Batch Dialog Settings:

Batch Validate Tree:

Batch Validate Files-  Clicking on this option in the tree window opens the batch compare session options dialog. Use these settings to load the files for comparison and control how the session will run. See below for specifics on each setting.

Analyze Options- This option opens the Tools>Options>Analyze Options which control the general options used to run the comparisons (what entity types to compare, geometry display settings...)

Secondary Options-  Opens  the Tools>Options>Analyze>Secondary Options dialog which have additional settings for the compare session (Topology/geometry count, Mass properties settings...)

Report Options- Shows the Tools>Options>Analyze>Report Options dialog which configures the session report for the batch compare.

Batch Validate Files Options:

Use these settings to load and control the batch compare session. Note that hitting Cancel will close the batch dialog, all Job Tree display data will be cleared. It is a good idea to use the Save Jobs to List option so you can repopulate when necessary.

 

Create New Single File Job- Left click to load session file Is/Was pairs one at a time. This is useful when files exist in multiple locations or you need to pick specific pairs in a given directory. The open dialog will first load the Is (copy file), then load the was (master file) file and then load a saved options file (User Dialog options by default which is provided on install in the Compare Options folder.) Note that each pairing can have its own unique options file producing differing session results based on which options file was selected. When in doubt of which options file to use, load and view using Compare>Load Options and Tools>Options>Analyze to review settings. Once complete the files will list in the Job Tree display area and the next pairing can be loaded.

 

Create New Directory Job- Left click to batch load file pairs using directory locations. The directory comparison functions much the same as the Compare>Compare Parts>File selection but prompts for directory locations to load the Is/Was files.

 

Load Jobs from List File- If a previously saved batch list exists (Save Jobs to List File was previously performed) it can be used to populate the Job Tree display.

 

Save Jobs to List File- Prior to using Load Jobs from List File this option is used to generate the Job Tree display list.

 

Select Server- Checking this option allows input of a server path, unchecked uses local path.

 

Report Directory- Specify the directory path where compare reports will be generated. The reports will be given the Is file name with report extension (.rpt, .html, .pdf....)

 

Write Session File- Checked will produce session files for the batch compare located by default in the Compare Options folder (saved as a .kvt session file with 'Is' file name.)

 

Maximum Number of Processes- Specify the number of processors to devote to the reading in of files (see Tools>Options>Misc for more details.)

 

Start/Stop-  Once the Job Tree is loaded and properly configured choose Start to begin processing the batch compare. Choose stop to halt the current process (choosing start again will process from the beginning.

 

Move Up/Down- Left click highlight a given row in the Job tree window and use these buttons to change the order of processing for a given  'Is'/'Was' pairing.

 

Cut/Paste- Left click highlight a given row in the job tree window and move using the cut and paste routine.

 

Delete- Left click highlight a given row in the job tree window and use delete to remove the pairing from the tree.

 

Validate- Choosing this will start the compare session.

 

Cancel- Hitting cancel will end the batch compare session. Note that the job tree content will not repopulate if you re-enter the Compare>Batch. It is a good idea to use the Save Jobs to List File prior to using cancel unless the job tree window content are no longer needed.

Job Tree Window:

The rows are populated with 'Is'/'Was' pairs using the available load options. The columns show category listing of job I.D. (starting at 0000 and increments by row) 'Is' file name, 'Was' file name, loaded options file for the pair and a Sub Compare listing (shows results of any sub compare as would be seen in an assembly file.) Right click on a highlighted row to bring up a context menu for opening the report for that pair or creating a log file for the pair (the log file gives a summary of the compare session processing.) Right click in the header area or a clear area in the Job Tree display brings up an additional context menu with the following options:

Select All- Highlights all rows within job tree window.

Copy Text- Copies any highlighted text in the job tree window which can then be edit-pasted into another application.

Text Out-  Creates a text document from highlighted rows in job tree window.

HTML Out- Creates a web document from highlighted rows in job tree window.

Save Current Column Layout- Saves the current column layout in job tree window.

Clear Saved Column Layout- Reverts to default column layout in job tree window.

Reset to Saved Column Layout- Sets column layout to that of the currently saved column layout in job tree window.

Reset to Default Column Layout- Changes the column layout to the default layout style in job tree window.

Expand Completely- Expands any collapsed rows within the job tree window

Collapse Completely- Collapse any expanded tree items in the job tree window.