Select
KeyCreator \ Tools \ Options \ Positioning-Selection \ Select

The Select dialog page contains various selection control methods.

Dialog Options:

Use Specific Chaining Tolerance instead of Coincident Distance

By default, the system uses the Coincident Distance specified in the File> Properties dialog for each part.  If you wish to override this value globally, select this option and enter the desired chaining tolerance below.

  • Chaining Tolerance - The allowable distance between entities' end points when you use any chaining selection. The default is .0002; the minimum value is .00001; the maximum value is .0002.

NOTE: The file-specific Coincident Distance setting is located in the Units/Tolerances tab of the File>Properties dialog.

Restrict chain select to CPlane

Check this setting to enable use of the Restrict Chain Select feature, also available from the Edit>System Settings submenu.

  • Depth Tolerance - If you restrict the chaining to the construction plane, the end of all the entities in the chain will lie on that plane exactly if the depth tolerance is zero.  The depth tolerance defines how far off the construction plane the end of the entity can be and still be considered on the plane for chain select purposes.  The depth tolerance allows you flexibility in the plane.  The default value of .0002 is taken from the chaining tolerance.

Enable Quick Chain Selection

Check this setting to enable use of the Quick Chain Selection feature, also available from the Edit>System Settings submenu.

Enable Manual Chain Direction Selection

When selected, chain selection asks you the direction of the chain. When cleared, chain selection automatically determines the direction, according to the picked position of the first entity.

Enable the Selection List

Check this setting to enable use of the Selection List feature, also available from the Edit>System Settings submenu.

More information on Selection List*Selection_Options

Enable Dynamic Entity Selection (CTRL to toggle temporarily)

Check this setting to enable use of the Dynamic Entity Selection feature, also available from the Edit>System Settings submenu. This feature operates in modeless and cursor selection modes and  highlights entities as the cursor moves over them previewing which entity will be selected upon the completion of a mouse click on the selection button.

  • Disable Dynamic Entity Selection During Fast Mouse Move – When selected, dynamic selection of entities will be turned off when the mouse cursor is moved rapidly through the program viewport.

  • Display Entity Selection Tooltips - When selected a Tooltip will appear below and to the right of the cursor displaying the entity type and name (if any) of the currently highlighted entity.

Enable Pre-Selection

Check this setting to enable use of the Pre-Selection feature, also available from the Edit>System Settings submenu.