Misc pane of the Set Configuration Options dialog can be used to set chaining tolerance values and cursor size, among several other options. "> Help | Kubotek3D

Misc
KeyCreator \ Tools \ Options \ Misc

The settings available from the Misc pane of the Set Configuration Options dialog can be used to set chaining tolerance values and cursor size, among several other options. 

Dialog Options:

Export Precision

This setting determines the number of significant digits exported for floating point values.  For example, if you specify 10, the number 10123.4567891234 would be exported (printed in a report as) 10123.45679. The default value of Export Precision is 10.

Among the functions that use the value specified in the Export Precision field are

  • File>Export>KXL

  • Tools>Record KXL Macro

  • Tools>Verify>Validate Parts

  • Detail>Settings>Settings, and click the Save button (which exports settings)

Minimum Sketch Polyline Increment

This is the minimum size of a line segment for polyline sketching.  The ranges allowable are the minimum distance (1e-10) and maximum distance (1e10). If a value outside of this range is entered, you will be prompted to re-enter a new value upon clicking OK or Accept. 

New Part Template

Allows you to select which template, if any, will load with the New Part (new .CKD).  If you do not intend for a template to load, the field can be left blank.

Enable Caching of CKD files for non-native file types

This function essentially links an import file type ( like a .sldasm SolidWorks file) with a cached version of the file as a .ckd file. Since the .ckd format is native to KeyCreator it will make any future loading of the file much quicker. The clear option clears the cache directory of all saved iteration of .ckd file while the Populate option allows you to preload the cache in a batch process. Use the maximum settings to control the overall size of the Cache directory (if nothing is set there is a potential that the directory will get very large over time.)

Enable Multi Process Reading of files

This option allows certain functions such as the Compare and Assembly read operations to take advantage of any multiple processors present on a given machine. This will improve performance and decrease time to process for the involved KeyCreator functions.

Re-enable All Disabled Warning Messages

Select this button to turn all disabled warning messages back on.  Messages can be individually disabled via a ”r;Don’t show this message again” checkbox in each warning dialog.

Allow Collection of anonymous data
Enabled this feature allows collection of tasks performed during a KeyCreator session.
This data can then be used to track future enhancement needs and possibly capture
errors that occur during a session, which can then be addressed by development.
Disable accelerators using Alt while in edit fields

When checked, accelerators that use the ALT key will be disabled while in edit fields.  This is useful if you wish to use the ALT key in an input field if it is otherwise required when executing accelerators instead.

Disable accelerators using Ctrl while in edit fields

When checked, accelerators that use the CONTROL key will be disabled while in edit fields. This is useful if you wish to use the CONTROL key in an input field if it is otherwise required when executing accelerators instead.

Disable accelerators using Shift while in edit fields

When checked, accelerators that use the SHIFT key will be disabled while in edit fields. This is useful if you wish to use the SHIFT key in an input field if it is otherwise required when executing accelerators instead.  This setting is checked by default.

Disable Unmodified Letters in Trees for Searching

This option effects keyboard shortcut focus when in a tree window selection operation.  When checked on the focus will be on the tree level function over any other set keyboard shortcut. An example would be if you are in a level list and left clicked on a level name called mylevel, there is  also a level called slevel.  Selecting s on your keyboard would cause a jump to the slevel (when this option is checked on.) If unchecked and hitting s on keyboard would bring up the Modify>Solid Face.

Display Help from the world wide web

 

Use this setting to get the most up to date help information using the kubotek3d.com help system. Disabled will default to the compiled html help located in KeyCreator\Lang\English\KeyCreator.chm.

Display Part Splitter on Right

The default location when opening the Part Splitter (which contains the level list, part reference tab...) is to the right of the display view, to switch sides use this option.

Enable Quick Key

This function allows for quickly changing the view, cplane, zoom, or viewport layout using the keyboard.  This method requires fewer keystrokes than using the immediate commands, and doesn't change what is displayed on the conversation bar. 

Maintain Default Menu Items

This check box applies to any menu (that is, displayed buttons) on the Conversation Bar that has a default button. When this check box is selected, the default button on the Conversation Bar becomes the last button used.

Synchronize Display View and CPlane Lists

If this option is enabled, when you create and name a new display view, a corresponding construction plane will be created as well.  The reverse is also true.  Unchecked, only the current view creation mode (display or construction) will be created. Applies to creation, renaming and deletion of the views.

Translate CKDOS special characters when loading files

This setting is checked (activated) by default.  It allows for special characters used in DOS versions to be translated into the current format when a file is loaded that contains them.

Mark old version files as modified when loaded for an assembly

The default behavior is to mark all files as changed which leads to a prompt for saving each loaded part reference file at closing/exiting (option is checked on). When this options is unchecked parts loaded which have part references will close/exit with a single prompt for  main assembly. When file locking is enabled parts loaded as part references will load as read only (not modified.)

Use Classic Mode menus

When checked, the classic mode menu and prompt line are displayed instead of the conversation bar.  The change will not affect the current keymap file as occurred in previous versions.

Use Classic Style Function Icons

When checked, the CADKEY for Windows style icons will be used. These icons are generally simpler than the default icons and use colored backgrounds to help indicate to which group they belong. After the switch is set, the software will need to be restarted before the change in icons will occur.