The Insert Object dialog box appears when Insert New Object is selected from the Edit Menu."> Help | Kubotek3D

OLE Dialog Options
KeyCreator \ Edit \ OLE-Functions \ OLE-Dialog-Options

Dialog Options:

The Insert Object dialog box appears when Insert New Object is selected from the Edit Menu.

image\EDIT_insertnewobject_dialog.gif
Create New

This setting opens the server application and lets you create new OLE object data.

  1. Specify the Object Type. The server application launches.

  2. Create new object data using the server application.

  3. Choose File>Update.

  4. Choose File>Exit and return to New Part. A rectangular window containing the object data appears.

  5. Position and size the window as desired. Click outside the window to deselect it.

Create from File

This setting allows you to embed or link an OLE object from a file created using a server application. A new dialog appears.

  1. Enter the path and filename or use the BROWSE button to select the name of the file you want to insert.

  2. If you want a link to the file, click on the Link checkbox. Any changes you make to an object are automatically reflected by the server application. Click OK.

  3. A rectangular window containing the object data appears.

  4. Position and size the window as desired. Click outside the window to deselect it. If the Display As Icon checkbox is enabled then the option to change the displayed icon becomes available through yet another dialog (see figure below) that is accessed through the CHANGE ICON button. This behavior is defined by Windows common dialogs, and will not be modified further.

image\EDIT_insertnewobject_icondialog.gif

 

Dragging and Dropping Objects:

Objects can be created, selected, and then dragged across the KeyCreator viewport.

  1. Create an object in a server application running standalone.

  2. Select the object.

  3. Drag the object and drop it in place using the mouse button.

 

Editing an OLE Object:

  1. Double-click on the object data's rectangular window. The server application opens.

  2. Make your changes.

  3. For embedded objects, choose File>Update and File>Exit and Return to New Part or Exit. You can also save linked objects.

  4. If the editing session occurs in a separate application window, use File>Exit to exit the editing mode. If the editing application has merged with Workshop, you must use the ESC key to exit the editing mode.