Configuration Options
KeyCreator \ Compare \ Compare-Configuration-Options \ Configuration-Options

Location:Tools>Options>Compare Options

This Dialog configures the basic Analyze/Compare options. Modified settings can be saved for later sessions using Compare>Save Options and later loaded using Compare>Load Options or by using the Options File selection in the File Selection dialog.  The Compare>Batch will show the current settings in the Batch Compare Tree. You can also open the configuration options using the Compare tool bar (turned on in Tools>Customize>Toolbars, check on the Compare box.)  

A second level of configuration further defines the comparison using the secondary Options dialog. When loading options the saved configuration data contained within Configuration Options, Secondary Options, Report Options and ECO Options will load for the current compare session.

Using this function:

  • Open the Configuration Options as mentioned above and modify settings as needed.

Analyze

Compare Direction

A compare can run in either a single direction or in both directions.  A bidirectional compare is used when one file contains more geometry then the other (the concern being any missing geometry in either file.) Use the directional options when trying to compare a subset of geometry in one file to the other file (not concerned with the extra geometry.) See the below example for more clarification.

Sets the tolerance threshold for running the Compare session. Typically set to the minimum acceptable compare value for the files units. Any measures below this threshold would then pass the compare. By default set to 0.001 (the best expected results from an IGES file.)

Angle Tolerance

Sets the angle degree tolerance threshold for the comparison.  Typically set to the minimum acceptable compare value for the files units. Any measures below this threshold would then pass the compare.

Annotation Tolerance

This will set a tolerance threshold for the envelope surrounding annotations, if annotations are outside this threshold the compare will flag.

Points on Faces

Choosing this options will compare points on solids/surfaces in both files exclusively and disregard all other geometric conditional options.  This setting will not process Mass Properties, Count topology and Count Geometry.  Using this option will compare a points file (this will be the 'Is' file in the compare) to solids/surfaces file (this will be the 'Was' file.)  Choosing this will leave the Points and Faces option selectable for further definition of the points compare. To aid in understanding which options to turn on and which to leave off see the below example.

Permit mixed math types

Allows for flexibility in face comparison when the faces would match but are derived from different geometric math types (example, a cylinder face that measures the same as a spline face would pass if this option is checked on.)

Points

Adds points to the compare task.

Curves

Adds curve geometry to the compare task.

Edges

Adds edge geometry to the compare task with a subset to permit split edges that would compare with non split edges when checked on.

Faces

Adds Face geometry to the compare task with a subset to allow for split and trimmed face comparison (on would pass face/ edge pair in one file with a matching single face/pair from the other file.)

Polygon Shells

Adds polygon shells to the compare task.

Annotations

Adds annotations to the compare task.

Annotation Captures

Adds any 'snap shot' annotation to the compare task.

Attributes

Adds common KeyCreator entity attributes (such as line type, line width, entity color..) to the compare task.

Assemblies

Tree+Parts dropdown -  Allows for a compare of either Tree+Parts ( compares file or reference name in tree, if matched, will then do a comparison on matched file/reference parts as a subcompare), flat (meaning compare all edges/faces in the references and show results in current session, must have Visualization Data checked off in Import>Options dialog.) or tree only.

Ref Names- For the tree compares choose either reference or file names.

Compare Names-  Choose to compare the file or reference names.

Flatten Standard Parts-  Ignores the assembly tree order when selected.

Ignore Name Indices-  Checked will ignore part name indices during comparison (checks indices in part numbers.).

Process Dash Number- Checked will compare dashes in part numbers.

Compare Matrices- Checked on will compare part positions.

Match by Matrices-  Checked will perform a compare by  part position and return a matched pair in tree (regardless of any naming discrepancies.)

Geometry Display

Face Surface Type

Sets the displayed color for the given geometry.

Display Options

 

Sort by

Sets the reports sort order by preferred method listed in drop down.

Is/ Was/ Disposition Color

Differentiates the Is/Was and the organization disposition status (if checked) colors.

Select

If all or some of the defaults are unchecked hitting select will reset to the default settings that are typically checked on.

Clear

Will uncheck all geometry filters and Assembly options.

 

 

Directional Compare Examples:

Points on Faces and subset effects: