Generating Keyboard Files
KeyCreator \ Tools \ Customize \ Commands \ Generating-Keyboard-Files

You can assign keyboard shortcuts using the Tools>Customize>Toolbars dialog menu, by assigning functions to specific keys. Browse the Categories list to find the program function icon. Its current key assignment will appear under Current Key, if one exists. To set or change this key assignment, select a new key combination. It will appear under Press New Shortcut Key. Select Assign Key to complete the assignment.

 

Any collection of Shortcut Keys that you create can be saved for later use, and/or designated as the system default. These collections of shortcut key assignments are called Keyboard Files.

This product is shipped with default keyboard settings to perform functions such as (Alt)-(F) to open the File Menu or (Alt)-(V) to change your display view. The Windows or Classic keyboard files can be selected during install. You can also create new keyboard files, or edit existing ones.

image\5_0_topic_header_PALETTE_copy.gif

  • Any function controls usually found in the Conversation Bar can be assigned to shortcut keys. The default for Windows functions will be the Windows Accelerator Keys, such as (Ctrl)-(O) to open an existing file. In addition, defaults are provided for many functions and commands. For DOS users, there is an Accelerator Key file designed to emulate the Immediate Mode structure in the DOS product.

  • All defaults can be customized.

  • Multiple shortcut keys can be assigned to the same function.

  • Toolbar buttons, keyboard assignments, and mouse button assignments cannot be created directly from the categories in the list, only from icons within the categories, even if the categories correspond to a palette button. The palette buttons themselves have their own categories. For instance, for the "Create-Line" button on the Modeling palette, you would select the Modeling-Create category, and select the Create Line icon.

 NOTE: Keyboard files have the .KBD extension and are located in the main install directory. .KBD files are ASCII text files and can be viewed and printed using the Windows Notepad application.

To view information on a Keyboard File topic, click the appropriate link below:

Creating Keyboard Files

Editing Keyboard Files

Default Shortcut Keys

Assigning Shortcut Keys to Macros

 

 

Saving Keyboard Combinations:

You can save your custom keyboard combinations to a file which can then be set as a default or loaded manually when needed. These files are called Keyboard Files. You can manage Keyboard Files from the Tools>Options>Startup dialog box.

 

Setting/Changing the Default Keyboard File:

The default keyboard file is changed/set through the Tools>Options>Startup dialog menu, under Keyboard Files. To change the current file, use the BROWSE button to select a new file. Use the LOAD and SAVE buttons to set the new file as the default. Keyboard assignments are saved to the active file when OK is selected in the Tools>Customize dialog.

  • Use the LOAD button to retrieve a saved keyboard file.

  • Use the SAVE button to save the currently loaded keyboard file.