Part splitter window is a dialog box with tabs whose panes are described below"> Help | Kubotek3D

Part Splitter Window
KeyCreator \ General-Interface \ Workspace \ Part-Splitter \ Part-Splitter-Window

 

Part Splitter Window

Function Location: View>Control Bars>Open Part splitter, Toggle Part Splitter

Using this function:

The Part splitter window is a dialog box with tabs whose panes are described below. You can control the display of the Part splitter window by clicking View>Control Bars and then clicking Open Part Splitter, Close Part Splitter or Toggle Part Splitter. Or, as shown in the figure below (which shows the workspace), you can drag it open or closed. Once opened you are presented with a series of tabs explained below.

image\solid_tut_level_list_window_hidden_for_kchelp.gif

Levels Tab:

The Levels tab of the Part splitter window displays the level tree for the current part, and allows you to set and change a variety of level attributes. By clicking in the appropriate cell, you are able to modify the information contained in the Level List Window. This can also be accomplished through the right-click context sensitive menu (left click on the level and right click to get context menu.)

The header cell title blocks indicate the focus of each of the columns in the Level List. You can modify the order in which the levels are displayed by clicking on each of the blocks. For expanded information regarding the Levels interface and Levels modification features, see Using the Levels Tab View> Level.

 

Part References Tab:

The Part References tab displays the reference tree for an assembly. Through this dialog, you can edit the parameters for references in the part. For more information on the available assemblies features, see Using Assemblies.

 

Level Sets Tab:

The pane that appears when you click the Level Sets tab allows you to control which levels are displayed through references to that part. Because there can be multiple level sets, different references can display different levels using different level sets.

This pane operates in the same manner as the Drawing Instance Levels pane in layout mode.   The Streamed column, when selected for a level set, saves the data necessary for lightweight assemblies for that level set. When cleared, the lightweight data is not saved with the part. For details, see Lightweight. For descriptions of the other column headers (Level Name, LNum, Count and Displayed), see Level List Window.

A level is only displayed if all of its parent levels are also displayed. Therefore, the box in the Displayed column is displayed as gray if any parent of the level is not displayed.

Level Sets can be created, renamed or deleted through the context menus.

There is one level set that cannot be renamed or deleted. This is the default level set, indicated by the name <Default>. Whenever a new level is created, that level is automatically displayed through the default level set.

 

Features Tab:

The Features tab displays a tree of the discovered features in the current part (such as Holes, Pockets, Chamfer, Boss for example.) When a feature is selected on a model using the Edit>Entities>Generic Edit function, this tree is displayed immediately. Through the tree, you can view and edit all of the available parameters for the selected feature. When a feature is selected in the tree, it automatically highlights on the model for easy recognition (unless that feature is suppressed). To populate the feature list use Create>Solid Feature>Discover Features.

To modify the available parameters for a selected feature, click on the feature to expand its tree. Select a parameter and click on the downward facing arrow for a list of available options.

 

Materials Tab:

The Materials tab allows you to double-click a sphere in the Materials pane to display the Material Rendering dialog box. Define the desired property on this dialog and click OK. Then the sphere has that property. Right click a sphere and choose the desired selection from the drop-down (Apply to Solid, Apply to Solid Face, Apply to Shell) Then drag the sphere onto the part thereby applying the property to the highlighted entity. To add a material right click in the Materials pane and choose New and name the material. If it is a listed material in the Textures folder within KeyCreator, simply use the name of the text file (an example would be the glass.txt file , simply name the new material glass and select load and choose the glass.txt file.) If you need to edit the material right click and choose Edit and modify the Material Rendering Properties as needed and click OK or to keep the modification for the material for future sessions choose Save. See Materials Rendering Properties for dialog setup.

 

 

Drawing Instances Tab (Layout Mode):

See Layout Instance Tab.