Tools>Customize>Viewport."> Help | Kubotek3D

Quick Eye
KeyCreator \ General-Interface \ Viewport \ Quick-Eye

Quick Eye

This function allows for quick zooming using the mouse. It is enabled through Tools>Customize>Viewport. Pressing and holding the right mouse button over a viewport activates the Quick Eye mode. The cursor changes to a hand holding a magnifying glass.

Quick Eye Notes:

  • Moving the mouse to the right causes the cursor to change to a "D" (for Double scale). Releasing the mouse button or stopping the movement of the mouse causes the view to be zoomed in by a factor of 2, and re-centered at the cursor position. Moving the mouse a larger distance to the right function before stopping or releasing changes the cursor to a "D" with a "3" (for Double scale 3 times), and the zoom to a factor of 8.

  • After the zoom, if the mouse button is still down, the cursor resets to the magnifying glass. Releasing the mouse button ends the Quick Eye mode and restores the regular cursor.

  • Moving the mouse in different directions results in different actions. Moving up zooms in by factors of 5 and 25 (represented by cursors "F" and "F2", for Five-times-scale, and Five-times-scale 2 times). Moving left zooms out by 2 or 8 (represented by "H" and "H3" for Half scale). Moving down immediately after entering Quick Eye mode results in an autoscale (represented by "A"). After an autoscale or zoom, moving down zooms out by factors of 5 and 25 (represented by "1/F" and "1/F3" for 1-Fifth scale).

  • The distance that the mouse must move before the any of the functions are activated, and the distance it must move before the larger zoom is used, is based on the Minimum Drag Window Size setting specified in Tools>Options>Display.

Quick Eye Settings under Tools>Customize>Viewport:

Moving in any of the four angled directions will cause a rubberband box to display around the regular cursor. To zoom to the window defined by the rubberband box, release the mouse button. This behavior can be modified for two of these directions through Tools>Customize>Viewport.

  • When Enable Up-Left as Viewport Layout Change in Quick Eye is enabled, moving up and to the left will cause the cursor to display the abbreviation "MV" (Multiple Viewports). Releasing the mouse button while this cursor is displayed will switch to the quad viewport layout if there is only one viewport. The viewport that is under the pointer when the quad viewport layout is entered, displays the same view as previously displayed rather than the view normally displayed in that viewport. If there are multiple viewports, releasing the mouse button will switch to a single viewport. This viewport displays the view of the viewport where you clicked the mouse pointer rather than the normal top view.

  • When Enable Up-Right as View Back is enabled, moving the cursor up and to the right will cause it to display the abbreviation "VB" (View Back). Releasing the mouse button while this cursor is displayed will jump back one state in the view history. See View Back for more information.

  • For both of the above operations, moving the cursor beyond the position where the button was initially pressed in either the X or Y direction will cancel the operation. No further Quick Eye processing will be done until a mouse button is released and pressed again.