Selection Options
KeyCreator \ General-Interface \ Selection \ Selection-Options

Selection Options

The Selection Menu defaults to a toggle selection method, drag and window select. You simply begin selecting the entities you want to manipulate by using the cursor. If you want to use one of the other selection options, simply select the appropriate button, then select the entity, or entities, and proceed with your changes. The options available from the Selection Menu are described below.

Single - By using Single, you will be allowed to select one entity at a time. The entity nearest the cursor is considered the current entity, and will be highlighted in the selection color that has been set. If the Selection Toggle (see below) is used, the next nearest entity will become the "current" entity.

Chain - Allows you to select a series of connected entities by first defining the start entity in the chain, then the direction in which you want to select the chain, and the end entity in the chain. Finally, you need to confirm whether the chaining selection is correct.

NOTE: If Quick Chain is enabled, only one selection is needed.

Blend Face Selection

Chain Selecting Faces of a Solid

Chain Circuit Selection

Chain Selecting Patterns

Window - This selection method requires that you create a left click and hold window around the entities you intend to manipulate.

Polygon - Requires that you create a closed polygon to select the entities inside that boundary or choose the Line method to create a pick trail using a polyline (see below for example.)

Group - Uses the cursor, or requires that you enter an assigned name to select grouped entities.

Plane - Select entities lying on a specified plane.

All Dsp - Select all entities displayed in a viewport; optionally, you can specify types to include or exclude.

Use Old - Only available if the Enable Selection List checkbox is checked under Tools>Options>Select. This allows you to use a previously defined selection of entities, which you can add to and subtract from.

Subtract - Switch to Subtract mode to deselect some of the entities you have already highlighted and exclude them from your selection. You can choose the selection method by which you want to deselect the entities.

Add - Appears after you have clicked the SUBTRACT button in case you now want to reselect additional entities, either new or ones you just deselected.

NOTE: The Subtract and Add settings do not affect the toggle selection from the Main Menu.

Clear - Selecting Clear will undo all previous selections, allowing you to start over.

 

Cursor Select/Deselect:

Select/Deselect entity mode is basically an on/off entity selection. It gives you the flexibility to select an entity, make your changes, and if you decide you do not want that particular entity to be selected you can click on it again to deselect it.

 

Building a Selection List from Multiple Selection Methods:

The multiple selection method allows you to use various selection types to pick entities. You do not have to hold down the CTRL key to keep selecting entities if the Select List checkbox is enabled (4) in the Select tab of the Set Configuration Options dialog box accessible from Tools>Options on the Menu bar. However if the Select List is not enabled you will need to use the CTRL key for multiple selection.

For example, if you need to change the attributes of a large portion of a model, but wish to keep the original color of a single entity within that portion, you would use this multiple selection method to avoid selecting the undesired entity, or entities.

NOTE: The CTRL key only needs to be held down during the very last keyboard or cursor action before the selection is complete. It does not need to be held down during the entire selection process.