Basic Chain Selection Options
KeyCreator \ General-Interface \ Selection \ Basic-Chain-Selection-Options

Basic Chain Select Options

The conversation bar selection menu contains many options to assist in entity selection. The Chain selection method will appear as one possible option depending on the operations being performed (Imprint Curves onto a Body, Cross Hatch, Edit Entity Attributes by selection to name a few.) The basic concept of chain selection is to choose a collection of entities which have a common end/start point (end of first entity and start of next entity  occupy the same position) along a given path without having to select each individually. Discussed below are the basic options seen when selecting chain select, for details on expanded options for other functions refer to the following topics:

Chain selecting faces of a solid

Blend face selection

 

Chain Select Conversation Bar Buttons

 

The conversation bar options for chain selection will be active when highlighted and will impart the highlighted options chain selection behavior. If a given option is not needed simply click to un-highlight (to add an option click to highlight.) Settings here will over ride any set in Tools>Options>Selection>Chain selection settings.

Curve- Will create the chain selection based on curve entities picked (Lines, arcs and splines for example.) This option will include the subset options for Direct, Quick, Repeat and Cpln Q:

Direct-Click direct and un-highlight the Quick option will prompt for first curve, a direction vector to choose and the next entities in the chain. Using the Quick method with Direct will simply use the Curve>Quick chain method. The direct method matches the setting in Tools>Options>Select, 'Enable Manual Chain Direction Selection.'

Quick- With Curve, Quick and CPln Q selected the chain selection will be highlighted based on the entity the mouse is currently on (focus is on the current Cplane.) With CPln Q off the chain selection will highlight any chain path regardless of current Cplane. This setting matches the Edit>System Settings>Quick Chain toggle function and the equivalent Tools>Options>Select setting.

Cpln Q- Available with the Quick option, this setting will focus the quick chain selection on the current Cplane. This setting matches the Edit>System Settings>Restrict Chain and Tools>Options>Select, 'Restrict Cahin Select to C-Plane.'

Repeat- When highlighted will allow multiple chain pattern selections when the Quick option is used, once complete choose Accept to progress to the choose additions conversation bar (again choose Accept when done.)

Circuit-  The edges on a body that form a closed trimmed boundary will automatically be detected when you move the mouse over them. Text will appear telling you how many entities form the boundary. Click to select the chain.

Pattern- This option is used for chain face pattern selection.