Quick Key
KeyCreator \ Tools \ Options \ Quick-Key

Quick Key

This function allows for quickly changing the view, cplane, zoom, or viewport layout using the keyboard. This method requires fewer keystrokes than using the immediate commands, and doesn't change what is displayed on the conversation bar. It is enabled through Tools>Options>Misc.

Using the Function:

  • To change to a new view, type the number of the view followed by the HOME key. When using multiple viewports, the one under the cursor is the one that will be affected.

  • To change to a new CPlane, type the number of the CPlane followed by the INSERT key.

  • To change to a new Viewport Layout, type the number followed by the END key. The number of the layout is its index within the View-Viewport Layout menu, with Single being 1, and Quad being 8. A value of 9 switches to the quad viewport layout if there is currently only one viewport, or the single viewport layout otherwise

  • To zoom in or out, enter the scale factor, followed by the DELETE key. Entering 0.5 is equivalent to the Zoom Half command, and 2 is equivalent to the Zoom Double command. In addition to zooming, the view is recentered at the current cursor position. Entering a scale of 0 performs an autoscale. When using multiple viewports, the one under the cursor is the one that will be affected.

  • Any numeric calculator expression using numbers and the characters below can be used as the input. When entering the value, the typed characters appear in the left-most field of the status bar. Pressing the backspace key will erase the last-entered character. Pressing the F10 or ESCAPE key on the keyboard will clear the current input.

NOTE: When this function is enabled, the number keys and the valid calculator characters "[]@()^.+-*/%" are not available for use in keyboard assignments. The Insert, Home, End, and Delete, Backspace, Escape, and F10 keys will execute the Quick Key function when there is a non-empty input string, rather than any keyboard assignments.