Levels Menus
KeyCreator \ View \ Control-Bars \ Part-Splitter \ Levels-Menus

Levels can be created and modified through a variety of menus, in addition to the View>Level submenu.

Right-Click Context Sensitive Menu (Header Level):

The menu shown below appears when you right click on the header area (Level Name) in the levels tab. See below for details on each item listed.

Select_All-   See the description under Options

Copy Text-  Captures the level name, level number, entity quantity and description for later Edit>Paste operations.

Text Out-  Records the level name, level number, entity quantity and description in a .txt.

HTML- Records the same as for the text file but saves in a .hmtl  format

Remember Column Layout– When selected, the current order and size of the columns are saved to the registry. Trees in all parts will feature the same column layout after this point. Note that the width of the splitter is still contained in the part. When you switch from Model Mode to Layout Mode for the first time for a particular part, a new tree is created.

Clear Column Layout Memory- Clears any saved column layout data from the registry.

When selected, the column layout saved in the registry is deleted, but the current tree is not affected. Any new trees that are created will open in the default column layout.

Recall Column Layout – When selected, the column layout of the current tree will be restored to match what is saved in the registry. Use this to revert back to a saved column layout after rearranging a tree or resizing columns in the current tree. This should also be used when you intend to update all other existing trees to a new column layout that had just been saved in one tree.

Reset Factory Column Layout – When selected, the column layout of the tree is restored to match the default column layout.

Expand Completely– See the description under Options.

Collapse Completely – When selected, the current item and its children is collapsed.

Right-Click Context Sensitive Menu (Level Root):

The menu shown below appears when you right click on the Level Root (top most entry) in the Levels tab.

Right-Click Context Sensitive Menu (Level or Sub-Level):

The right-click context sensitive menu shown below appears when you right click on a level (or sub-level) in the Levels tab. Note that several of these functions may appear in the View>Level submenu and/or your Level toolbar.

To view information on a particular function, click the appropriate function name.

Custom Toolbar:

A toolbar containing the levels options can be created through the Tools>Customize pull-down menu.